TT problems

Topics that relate to the All-In-One Testkit
User avatar
Administrator
Site Admin
Posts: 24
Joined: Sun Jan 03, 2016 5:23 pm
Contact:

TT problems

Postby Administrator » Sun Jan 03, 2016 8:00 pm

Some TTs (mainly older ones with CPU daughterboard) seem to have troubles starting if an ST-RAM expansion board is installed. The diagnosis software boots if the expansion is removed.
TTs and Falcon 030 do have a fuse installed on the mainboard that limits the current drawn by a ROM-Port expansion (500mA fuse). I have seen quite often that this particular fuse is blown. Sometimes the inductor nearby, too. In this case the Atari won't boot with the testkit activated and the LED is prone to flicker. Either check the +5V ROM port voltage with an oscilloscope (voltmeter probably lags too much) or open the Atari and check fuse/inductor.
User avatar
Administrator
Site Admin
Posts: 24
Joined: Sun Jan 03, 2016 5:23 pm
Contact:

Re: TT problems

Postby Administrator » Sat Jul 23, 2016 8:02 am

Another problem with testcart's software V1.5 for TT arose lately.
I put an aixTT FastRAM card in my TT test-rig, did not populate any PS/2 SIMM socket and what happened? The testcart did detect 16MB TT RAM. :o
I put in an original Atari card with 4MB and it was detected correctly. Same with a MightyMic32B and 8MB in total SIMMs. I put 4MB onto the aixTT and it detected 16MB. Needless to say that any access during RAM test above $013FFFFF went wrong!
As Atari's own FastRAM card maxed out at 16MB they did not implement detection of more than 16MB FastRAM.
So I patched the testcart's software for TTs in two ways:
  • up to 1024MB of Fast-RAM are detected and printed on the main menu and after the RAM test
  • the RAM detection algorithm has been reworked
The RAM test algorithm itself has not been touched!

Image

Image
crashman
Posts: 8
Joined: Wed Mar 30, 2016 12:17 am
Contact:

Re: TT problems

Postby crashman » Sun Feb 04, 2018 3:51 pm

Hi!
could you post the file again?
I only get a zip error when I try to open it.
Thanks.
crashman
Posts: 8
Joined: Wed Mar 30, 2016 12:17 am
Contact:

Re: TT problems

Postby crashman » Fri Feb 09, 2018 10:37 pm

Now it's perfect, thanks!!!

Who is online

Users browsing this forum: No registered users and 1 guest